Compartilhe
Ir em baixo
avatar

Mensagens : 8
Pontos : 30
Ver perfil do usuário

[Resolvido][Dúvida] Erro ao compilar

em Ter 1 Abr 2014 - 17:30
Estou tentando compilar meu servidor mais quando chego na parte do CMaker da o seguinte erro:
Detected 32-bit platform
Using supplied MySQL sources
CMake Error at cmake/compiler/msvc/settings.cmake:7 (message):
MSVC: TrinityCore requires version 18.0 (MSVC 2013) to build but found
16.0.30319.1
Call Stack (most recent call first):
cmake/platform/win/settings.cmake:29 (include)
cmake/macros/CheckPlatform.cmake:13 (include)
CMakeLists.txt:48 (include)


Configuring incomplete, errors occurred!

Me Ajude Galera PF !!

Mensagens : 1091
Pontos : 25172
Ver perfil do usuário

Re: [Resolvido][Dúvida] Erro ao compilar

em Ter 1 Abr 2014 - 17:52
Olá,
instala o Vertrigo ou algum mysql que seja de instalação.

Resolvido?

Até mais.
avatar

Mensagens : 210
Pontos : 927
Ver perfil do usuário

Re: [Resolvido][Dúvida] Erro ao compilar

em Ter 1 Abr 2014 - 19:22
dlinklol escreveu:CMake Error at cmake/compiler/msvc/settings.cmake:7 (message):
MSVC: TrinityCore requires version 18.0 (MSVC 2013) to build but found
16.0.30319.1

Configuring incomplete, errors occurred!
 baixa o microsoft visual c++ express 2013, e configura o cmake dnovo
avatar

Mensagens : 8
Pontos : 30
Ver perfil do usuário

Re: [Resolvido][Dúvida] Erro ao compilar

em Ter 1 Abr 2014 - 23:09
Instalei mais quando fui configurar o CMake não tinha opção do express 2013 coloquei 2012 mais o erro mudo para esse:

CMake Error at C:/Program Files (x86)/CMake 2.8/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:108 (message):
Could NOT find OpenSSL (missing: OPENSSL_LIBRARIES OPENSSL_INCLUDE_DIR)
Call Stack (most recent call first):
C:/Program Files (x86)/CMake 2.8/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:315 (_FPHSA_FAILURE_MESSAGE)
cmake/macros/FindOpenSSL.cmake:176 (find_package_handle_standard_args)
CMakeLists.txt:56 (find_package)
avatar

Mensagens : 210
Pontos : 927
Ver perfil do usuário

Re: [Resolvido][Dúvida] Erro ao compilar

em Qua 2 Abr 2014 - 0:11
dlinklol escreveu: Could NOT find OpenSSL (missing: OPENSSL_LIBRARIES OPENSSL_INCLUDE_DIR)

vc não instalou o OpenSSL, baixa ele aqui e instale.
avatar

Mensagens : 619
Pontos : 2179
Evolução : 5

Ver perfil do usuáriohttp://www.mthsena.info

Re: [Resolvido][Dúvida] Erro ao compilar

em Qua 2 Abr 2014 - 0:20
dlinklol escreveu:Instalei mais quando fui configurar o CMake não tinha opção do express 2013 coloquei 2012 mais o erro mudo para esse:

CMake Error at C:/Program Files (x86)/CMake 2.8/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:108 (message):
Could NOT find OpenSSL (missing: OPENSSL_LIBRARIES OPENSSL_INCLUDE_DIR)
Call Stack (most recent call first):
C:/Program Files (x86)/CMake 2.8/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:315 (_FPHSA_FAILURE_MESSAGE)
cmake/macros/FindOpenSSL.cmake:176 (find_package_handle_standard_args)
CMakeLists.txt:56 (find_package)

É esse mesmo, o compilador do 2013 é o mesmo do 2012.
E atenção, 2013 compilação padrão só funciona em windows 7 acima.
Caso precise usar no xp, 2003, mude o toolset.
avatar

Mensagens : 8
Pontos : 30
Ver perfil do usuário

Re: [Resolvido][Dúvida] Erro ao compilar

em Qua 2 Abr 2014 - 0:33
Agora já mudo erro:

The C compiler identification is MSVC 18.0.21005.1
The CXX compiler identification is MSVC 18.0.21005.1
Check for working C compiler using: Visual Studio 12
Check for working C compiler using: Visual Studio 12 -- works
Detecting C compiler ABI info
Detecting C compiler ABI info - done
Check for working CXX compiler using: Visual Studio 12
Check for working CXX compiler using: Visual Studio 12 -- works
Detecting CXX compiler ABI info
Detecting CXX compiler ABI info - done
Detected 32-bit platform
Using supplied MySQL sources
MSVC: Enabled large address awareness
MSVC: Enabled SSE2 support
MSVC: Overloaded standard names
MSVC: Disabled NON-SECURE warnings
MSVC: Disabled POSIX warnings
MSVC: Disabled generic compiletime warnings
Found OpenSSL library: optimized;C:/OpenSSL-Win32/lib/VC/ssleay32MD.lib;C:/OpenSSL-Win32/lib/VC/libeay32MD.lib;debug;C:/OpenSSL-Win32/lib/VC/ssleay32MDd.lib;C:/OpenSSL-Win32/lib/VC/libeay32MDd.lib
Found OpenSSL headers: C:/OpenSSL-Win32/include
Looking for include file pthread.h
Looking for include file pthread.h - not found
Found Threads: TRUE
CMake Error at cmake/macros/FindGit.cmake:24 (message):


Git was NOT FOUND on your system - did you forget to install a recent version, or setting the path to it?
Observe that for revision hash/date to work you need at least version 1.7
Call Stack (most recent call first):
CMakeLists.txt:70 (find_package)


Configuring incomplete, errors occurred!
See also "C:/Build/CMakeFiles/CMakeOutput.log".
See also "C:/Build/CMakeFiles/CMakeError.log".
avatar

Mensagens : 210
Pontos : 927
Ver perfil do usuário

Re: [Resolvido][Dúvida] Erro ao compilar

em Qua 2 Abr 2014 - 0:46
dlinklol escreveu:
CMake Error at cmake/macros/FindGit.cmake:24 (message):


Git was NOT FOUND on your system - did you forget to install a recent version, or setting the path to it?
Observe that for revision hash/date to work you need at least version 1.7
instalou o Git??? se não --> GitExtensions
avatar

Mensagens : 8
Pontos : 30
Ver perfil do usuário

Re: [Resolvido][Dúvida] Erro ao compilar

em Qua 2 Abr 2014 - 1:22
Sim,Continua mesmo erro !
avatar

Mensagens : 210
Pontos : 927
Ver perfil do usuário

Re: [Resolvido][Dúvida] Erro ao compilar

em Qua 2 Abr 2014 - 2:03
dlinklol escreveu:Sim,Continua mesmo erro !
então reinstale o Git e durante a instalação marque essa opção :
[Você precisa estar registrado e conectado para ver esta imagem.]
avatar

Mensagens : 8
Pontos : 30
Ver perfil do usuário

Re: [Resolvido][Dúvida] Erro ao compilar

em Qua 2 Abr 2014 - 12:35
Galera esta dando outro erro quando chego na parte do SQL Vertrigo quando executo ele fica  a sim:

tinypic.com/view.php?pic=oho0hy&s=8

E quando vou tentar fazer uma nova conexão da esse erro:

tinypic.com/view.php?pic=2wqefs9&s=8#.UzxpqVebKVg

Teria outro programa sem ser o Vertrigo!

Peço a ajuda de vocês novamente ajuda ae galera PF !!
avatar

Mensagens : 1827
Pontos : 7296
Evolução : 2

Ver perfil do usuáriohttp://www.fury-share.blogspot.com.br/

Re: [Resolvido][Dúvida] Erro ao compilar

em Qua 2 Abr 2014 - 19:10
[Você precisa estar registrado e conectado para ver este link.]

Mensagens : 1091
Pontos : 25172
Ver perfil do usuário

Re: [Resolvido][Dúvida] Erro ao compilar

em Qua 2 Abr 2014 - 20:18
dlinklol escreveu:Galera esta dando outro erro quando chego na parte do SQL Vertrigo quando executo ele fica  a sim:

tinypic.com/view.php?pic=oho0hy&s=8

E quando vou tentar fazer uma nova conexão da esse erro:

tinypic.com/view.php?pic=2wqefs9&s=8#.UzxpqVebKVg

Teria outro programa sem ser o Vertrigo!

Peço a ajuda de vocês novamente ajuda ae galera PF !!
Olá,
Tem o Easyphp ou mysql portable, porem não tenho o link de download.

Evite 2 dúvidas ou mais em 1 tópico, leia as regras.

a primeira dúvida está resolvida?

Até mais.
avatar

Mensagens : 210
Pontos : 927
Ver perfil do usuário

Re: [Resolvido][Dúvida] Erro ao compilar

em Qua 2 Abr 2014 - 20:54
dlinklol escreveu:Galera esta dando outro erro quando chego na parte do SQL Vertrigo quando executo ele fica  a sim:

tinypic.com/view.php?pic=oho0hy&s=8
vai no vertrigo > Config Files > httpd.conf, abre e procura "Listen 80" e muda pra "Listen 90" , salva e da restart no vertrigo.

dlinklol escreveu:E quando vou tentar fazer uma nova conexão da esse erro:

tinypic.com/view.php?pic=2wqefs9&s=8#.UzxpqVebKVg
usuário ou senha incorreto.
avatar

Mensagens : 8
Pontos : 30
Ver perfil do usuário

Re: [Resolvido][Dúvida] Erro ao compilar

em Qua 2 Abr 2014 - 23:02
Tentei com o wampServer deu isso:

tinypic.com/view.php?pic=6ib7v6&s=8#.UzzAvVebKVg

Com o VertrigoServ:

tinypic.com/view.php?pic=oawzy8&s=8
avatar

Mensagens : 210
Pontos : 927
Ver perfil do usuário

Re: [Resolvido][Dúvida] Erro ao compilar

em Sex 4 Abr 2014 - 12:21
dlinklol escreveu:Com o VertrigoServ:

tinypic.com/view.php?pic=oawzy8&s=8

Olá dlinklol,  
parece que você já tem outro MySQL sendo executado, por isso esse erro.Abra o gerenciador de tarefas, procure por "mysqld", feche todos os serviços, e reinicie o Vertrigo.

Atenciosamente Paradox. ;-)
avatar

Mensagens : 1827
Pontos : 7296
Evolução : 2

Ver perfil do usuáriohttp://www.fury-share.blogspot.com.br/

Re: [Resolvido][Dúvida] Erro ao compilar

em Sab 5 Abr 2014 - 14:35
O do WampServer é porque está faltando DLL, se não me engano são duas, agora os nomes não me lembro, clique no ícone do WampServer, vá em Apache/Service e clique em Instalar Serviço, quando for instalar mostrará as dlls que estão faltando
avatar

Mensagens : 210
Pontos : 927
Ver perfil do usuário

Re: [Resolvido][Dúvida] Erro ao compilar

em Ter 10 Jun 2014 - 18:03
Como a duvida inicial foi aparentemente solucionada, estou finalizando o tópico.

Tópico Trancado e movido Para sua área correspondente.
Conteúdo patrocinado

Re: [Resolvido][Dúvida] Erro ao compilar

Voltar ao Topo
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum