Bgames
Olá visitante! Seja bem vindo ao nosso fórum!

Para você ter total acesso ao nosso fórum é preciso que você se cadastre.

Cadastre-se Aqui!


PARA VER LINKS E IMAGENS É PRECISO SE REGISTRAR!

Problema para instalar o gcc

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Problema para instalar o gcc

Mensagem por Cabroon em Ter 20 Ago 2013 - 15:10

Oi pessoal da bgames!
Recentemente instalei o linux fedora 19, para que eu podesse compilar codigos em c++ no terminal linux usando o gcc. Mas Estou com um problema ja coloquei o comando "yum install gcc", tambem coloquei o codigo  como root, mas mesmo assim não comsegui.

Aparece a seguinte mensagem:

Código:
[paulos@localhost ~]$ su
Senha:
[root@localhost paulos]# yum install gcc
Plugins carregados: langpacks, refresh-packagekit
Resolvendo dependências
--> Executando verificação da transação
---> O pacote gcc.x86_64 0:4.8.1-1.fc19 será instalado
--> Processando dependência: cpp = 4.8.1-1.fc19 para o pacote: gcc-4.8.1-1.fc19.x86_64
--> Processando dependência: glibc-devel >= 2.2.90-12 para o pacote: gcc-4.8.1-1.fc19.x86_64
--> Processando dependência: libmpc.so.3()(64bit) para o pacote: gcc-4.8.1-1.fc19.x86_64
--> Executando verificação da transação
---> O pacote cpp.x86_64 0:4.8.1-1.fc19 será instalado
---> O pacote glibc-devel.x86_64 0:2.17-11.fc19 será instalado
--> Processando dependência: glibc-headers = 2.17-11.fc19 para o pacote: glibc-devel-2.17-11.fc19.x86_64
--> Processando dependência: glibc-headers para o pacote: glibc-devel-2.17-11.fc19.x86_64
---> O pacote libmpc.x86_64 0:1.0.1-1.fc19 será instalado
--> Executando verificação da transação
---> O pacote glibc-headers.x86_64 0:2.17-11.fc19 será instalado
--> Processando dependência: kernel-headers >= 2.2.1 para o pacote: glibc-headers-2.17-11.fc19.x86_64
--> Processando dependência: kernel-headers para o pacote: glibc-headers-2.17-11.fc19.x86_64
--> Executando verificação da transação
---> O pacote kernel-headers.x86_64 0:3.10.6-200.fc19 será instalado
--> Resolução de dependências finalizada

Dependências resolvidas

================================================================================
 Package              Arq.         Versão                   Repo           Tam.
================================================================================
Instalando:
 gcc                  x86_64       4.8.1-1.fc19             fedora         16 M
Instalando para as dependências:
 cpp                  x86_64       4.8.1-1.fc19             fedora        5.9 M
 glibc-devel          x86_64       2.17-11.fc19             updates       1.0 M
 glibc-headers        x86_64       2.17-11.fc19             updates       643 k
 kernel-headers       x86_64       3.10.6-200.fc19          updates       874 k
 libmpc               x86_64       1.0.1-1.fc19             fedora         49 k

Resumo da transação
================================================================================
Instalar  1 Package (+5 Dependent packages)

Tamanho total: 24 M
Tamanho total do download: 874 k
Tamanho depois de instalado: 58 M
Is this ok [y/d/N]:
Ai eu coloco "y" e clico em enter:
Então aparece isso:

Código:
Downloading packages:
kernel-headers-3.10.6-200.fc19 FAILED                                         
http://mirror.globo.com/fedora/linux/updates/19/x86_64/kernel-headers-3.10.6-200.fc19.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Tentando outro espelho.
kernel-headers-3.10.6-200.fc19 FAILED                                         
http://www.las.ic.unicamp.br/pub/fedora/linux/updates/19/x86_64/kernel-headers-3.10.6-200.fc19.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Tentando outro espelho.
kernel-headers-3.10.6-200.fc19 FAILED                                         
http://fedora.c3sl.ufpr.br/linux/updates/19/x86_64/kernel-headers-3.10.6-200.fc19.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Tentando outro espelho.
kernel-headers-3.10.6-200.fc19 FAILED                                         
http://fedora.gtdinternet.com/updates/19/x86_64/kernel-headers-3.10.6-200.fc19.x86_64.rpm: [Errno 14] HTTP Error 404 - Not Found
Tentando outro espelho.
Alguem sabe o que eu posso estar fazendo para resolver este problema?
Agradeço desde ja!

Cabroon


Mensagens : 229
Pontos : 671

Ver perfil do usuário http://www.qtorrentrapido.blogspot.com.br

Voltar ao Topo Ir em baixo

Re: Problema para instalar o gcc

Mensagem por The Green Reaper em Ter 20 Ago 2013 - 15:28

parece estar baixando algo e sempre falha e tenta outro mirror(mirror é tipo:4shared,Mediafire,etc)

não posso lhe ajudar porque não entendo codigos ¬¬

tente baixar algun aquivo com o nome ''kernel-headers'' ou ''kernel headers'',não sei se é isso,mas parece algo essencial para
rodar esse programa

edit:persebi um codigo errado ali,quando da erro no download escreve [Errno 14] e da erro 404 por que não
reconheceu o comando,acho que arrumaria se estivesse assim:
[Erro 14] inves de [Errno 14],mas não sei não...

The Green Reaper


Mensagens : 39
Pontos : 115

Ver perfil do usuário http://designbrosdotme.wordpress.com/

Voltar ao Topo Ir em baixo

Re: Problema para instalar o gcc

Mensagem por Cabroon em Ter 20 Ago 2013 - 17:57

Pesquisando aqui consegui encontrar um instalador gcc para o terminal linux
Site:
http://rpm.pbone.net/index.php3/stat/4/idpl/21937433/dir/fedora_19/com/gcc-4.8.1-1.fc19.i686.rpm.html

Para instalar basta executar ele!

To deixando ai a solução para quem tiver com mesmo problema. Obrigado para os que me ajudarão tambem!

Topico Resolvido, pode trancar!

Cabroon


Mensagens : 229
Pontos : 671

Ver perfil do usuário http://www.qtorrentrapido.blogspot.com.br

Voltar ao Topo Ir em baixo

Re: Problema para instalar o gcc

Mensagem por Conteúdo patrocinado Hoje à(s) 12:58


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum