Bgames
Olá visitante! Seja bem vindo ao nosso fórum!

Para você ter total acesso ao nosso fórum é preciso que você se cadastre.

Cadastre-se Aqui!


PARA VER LINKS E IMAGENS É PRECISO SE REGISTRAR!

Comando não funciona

Página 2 de 2 Anterior  1, 2

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Re: Comando não funciona

Mensagem por Switch em Qua 7 Ago 2013 - 15:42

Cara se você não sabe o que fazer mesmo depois deu ter apontado os erros não vou poder te ajudar tanto, mas vou tentar.

1° - Ótimo você remover os html como eu falei.

2° - Verificar se o submit foi enviado.

Isso é para garantir a segurança.

Código:
<?php
if(isset($_POST['enviar'])){
//todo resto do código aqui
}else{
header('Location: index.php');
}
?>

Pronto, resolvemos outra falha.

3° - session_start()
você só está chamando essa função no final do código, desse modo ela não funciona, ele deve estar no topo da página.
Olha esse código: [Você precisa estar registrado e conectado para ver este link.]
Foi o primeiro de login que eu fiz.

Repare que a função session_start() vem antes do include do config.php , se ela viesse depois iria dar erro como está acontecendo com o seu.

4° - Validação das variáveis.
O código que eu passei ta tão inseguro quanto o seu, mas como forma de prevenção eu usei a função addslashes() , isso já ajuda a prevenir pequenos códigos SQL que algum usuário pode passar, mas tem que usar outros códigos e alguns métodos além disso.


Bom expliquei as coisas e tentei te dar um "norte" para você seguir, é bom você ler algumas apostilas de php e procurar tutoriais básicos para iniciantes.
avatar
Switch


Mensagens : 221
Pontos : 751

Ver perfil do usuário

Voltar ao Topo Ir em baixo

O autor desta mensagem foi removido do fórum - Ver a mensagem

Página 2 de 2 Anterior  1, 2

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo


 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum